DTop CMS - система управления контентом
Текущая версия: 3.4.1



© 2002-2013

Статья опубликована: 2011.05.19


В стандартный дистрибутив CentOS 5.6 входит PHP версии 5.3. Но для некоторых CMS необходим PHP версии 5.2 так как на PHP 5.3 они глючат.
  • Использованные версии ПО:
    # uname -sr
    CentOS-56-64-minimal 2.6.18-238.9.1
    
  • Установка

    Вначале необходимо избавиться от уже установленной PHP. Проверяем присутствие PHP в системе:
    # rpm -qa | grep php-
    
    Если вывод данной команды пустой, это означает, что PHP не установлен.
    При наличии в системе установленного PHP, его предварительно необходимо удалить:
    # yum erase php-*
    
    Затем любым способом редактируем файл (если файла нет, то его нужно создать)
    /etc/yum.repos.d/CentOS-Testing.repo
    [c5-testing]
     name=CentOS-5 Testing
     baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
     enabled=1
     gpgcheck=1
     gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
     includepkgs=php*
    
    После этого устанавливаем php
    # yum install php php-mcrypt php-mysql php-gd
    
    Проверяем:
    # rpm -qa | grep php-
    php-common-5.2.10-1.el5.centos
    php-cli-5.2.10-1.el5.centos
    php-gd-5.2.10-1.el5.centos
    php-5.2.10-1.el5.centos
    php-pdo-5.2.10-1.el5.centos
    php-mcrypt-5.2.9-2.el5.centos.3
    php-mysql-5.2.10-1.el5.centos